Instalando os componentes de integração para Hyper-V no Linux CentOS

 

Pessoal, tive essa necessidade há um tempo e estou compartilhando com vocês.

Introdução

Para que o Linux CentOS consiga reconhecer as interfaces de rede nativas Hyper-V, é necessário alguns passos.

1. Download dos componentes de integração para Linux

Realize o download do exe aqui. Copie a iso para o servidor do Hyper-V e adicione a midia à máquina Linux.

2. Instalação

Para a instalação, é necessário o “Development Tools”. O caminho mais curto é via Yum.

yum groupinstall "Development Tools"

Ou utilize os pacotes rmps que estão armazenados no próprio cd do CentOS.

Em seguida, execute essa seqüência de comandos

mkdir -p /mnt/cdrom
mount /dev/cdrom /mnt/cdrom
cp -rp /mnt/cdrom /opt/linux_ic
umount /mnt/cdrom

Em seguida, vamos criar uma nova imagem initrd com os drivers necessários:

cd /opt/linux_ic
./setup.pl drivers

Reinicie a VM Linux e execute o seguinte comando para verificar se o driver foi instalado:

lsmod | grp vsc

netvsc                 73704  0
storvsc                66824  0
blkvsc                 70440  3
vmbus                  86120  3 netvsc,storvsc,blkvsc
scsi_mod              196569  6 scsi_dh,sg,storvsc,blkvsc,libata,sd_mod

Se o driver sintético foi instalado corretamente, com ifconfig -a aparecerá uma interface seth0.

Abraços,

Carlos Monteiro.

Tags: , , ,

3 Respostas to “Instalando os componentes de integração para Hyper-V no Linux CentOS”

  1. Suporte à mouse no Hyper-V para Linux CentOS « Carlos Monteiro's Blog Says:

    […] Instalar os componentes de integração para Linux (existe um post antigo onde explico esse procedimento); – Faça o download de “inputvsc.iso” em […]

  2. Leonardo Pauleti Says:

    Olá, você notou que o CentOS no Hyper-v não aceita mais que 4GB, em pesquisar verifiquei que se trata de uma caracteristica do proprio CentOs que para resolver bastava instalar o pacote, kernel-PAE, no entanto não funcionou, continua o mesmo.

    Já teve este problema?

    • carlosedmonteiro Says:

      Olá Leonardo!
      Tive um colega que passou por uma situção semelhante, mas ele comentou que realmente foi instalar o suporte PAE no CentOS e funcionou. Outro caminho, não conheço.
      Abraços,
      Carlos.

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s


%d blogueiros gostam disto: